Select Language:
Installation Wizard
Loaded Commerce CE v6.5.3

Loaded Commerce CE v6.5.3

Welcome to Loaded Commerce CE v6.5.3. This software has been engineered to meet the technical security requirements of the Payment Card Industry Data Security Standards.

  • If you are setting up a NEW STORE with Loaded Commerce CE v6.5.3, click the button on the left labeled NEW STORE.

  • If you are UPGRADING your store from an earlier version of Loaded Commerce (Fromerly CRE Loaded) to the new Loaded Commerce CE v6.5.3, please click on the button on the right labeled UPGRADE.

Requires Loaded Commerce v6.2 or v6.3 or v6.4

NEW STORE
UPGRADE